预览模式: 普通 | 列表

PHP 白河子在线报名系统1.0

白河子asp成绩查询系统4.0

实现步骤:
一:在http://phpexcel.codeplex.com/下载最新PHPExcel放到Vendor下,注意位置:ThinkPHP\Extend\Vendor\PHPExcel\PHPExcel.php。
二:导出excel代码实现

    /**方法**/

查看更多...

分类:php | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 55

USG5320A Config:
#配置接口IP
interface GigabitEthernet0/0/0
description TO_CoreSW_A
ip address 192.168.63.2 255.255.255.0
interface GigabitEthernet0/0/1
description TO_FWB
ip address 192.168.59.1 255.255.255.0
interface GigabitEthernet0/0/3            
description TO_LIANTONG
ip address x.x.x.x 255.255.255.240
#将接口加入zone
firewall zone trust
set priority 85
add interface GigabitEthernet0/0/0
add interface GigabitEthernet0/0/1
firewall zone untrust
set priority 5
add interface GigabitEthernet0/0/3
#配置域间策略
policy interzone trust untrust outbound
policy 1
action permit
policy source 10.0.0.0 0.0.255.255
policy source 172.16.0.0 0.0.255.255
#配置NAT策略
nat address-group 0 LIANTONG x.x.x.x 255.255.255.240
nat-policy interzone trust untrust outbound
policy 1
action source-nat
policy source 172.16.0.0 0.0.255.255
policy source 10.0.0.0 0.0.255.255
address-group LIANTONG
#配置链路可达性检查并与静态路由绑定
ip-link check enable
ip-link 1 destination x.x.x.z timer 5 mode icmp
ip route-static 0.0.0.0 0.0.0.0 x.x.x.z preference 50 ip-link 1
ip route-static 0.0.0.0 0.0.0.0 192.168.59.2
ip route-static 10.0.0.0 255.255.0.0 192.168.63.1
ip route-static 172.16.0.0 255.255.0.0 192.168.59.2


USG5320B Config:
#配置接口IP
interface GigabitEthernet0/0/0
description TO_CoreSW_B
ip address 192.168.62.2 255.255.255.0
interface GigabitEthernet0/0/1
description TO_FWA
ip address 192.168.59.2 255.255.255.0
interface GigabitEthernet0/0/3            
description TO_DIANXIN
ip address y.y.y.y 255.255.255.240
#将接口加入zone
firewall zone trust
set priority 85
add interface GigabitEthernet0/0/0
add interface GigabitEthernet0/0/1
firewall zone untrust
set priority 5
add interface GigabitEthernet0/0/3
#配置域间策略
policy interzone trust untrust outbound
policy 1
action permit
policy source 10.0.0.0 0.0.255.255
policy source 172.16.0.0 0.0.255.255
#配置NAT策略
nat address-group 0 DIANXIN y.y.y.y 255.255.255.240
nat-policy interzone trust untrust outbound
policy 1
action source-nat
policy source 172.16.0.0 0.0.255.255
policy source 10.0.0.0 0.0.255.255
address-group DIANXIN
#配置链路可达性检查并与静态路由绑定
ip-link check enable
ip-link 1 destination y.y.y.z timer 5 mode icmp
ip route-static 0.0.0.0 0.0.0.0 y.y.y.z preference 50 ip-link 1
ip route-static 0.0.0.0 0.0.0.0 192.168.59.1
ip route-static 172.16.0.0 255.255.0.0 192.168.62.1
ip route-static 10.0.0.0 255.255.0.0 192.168.59.1

注:
1、        当IP-Link自动侦测发现链路故障时,USG5300会将下一跳IP地址是IP-Link链路探测的目的IP地址的静态路由置为非激活状态,用display fib可以发现与IP-Link绑定的路由已经消失;同时防火墙会对自身的静态路由进行,选择次优静态路由,保持业务的持续。
2、        USG5300版本号V100R003SPC300才可支持IP-Link与静态路由绑定;
3、        IP-Link链路探测的目的IP地址必须与静态路由的下一跳IP地址相同;
4、        上面的配置虽然实现了运营商链路的冗余,但是如果核心交换VRRP主备倒换,则会出现办公区1或者办公区2上不了internet的情况,VRRP此时只能保证3层及以下数据的互通(无语,想了半天还是没有想出什么好的解决方法),保证VRRP的稳定只能靠设备了(双主控+双电源)。
还是希望有经验的朋友给出一个完整的解决方案,感觉这次配置还是有问题的,好多问题没有解决。

 

分类:学校网络 | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 79

华为三层交换机与防火墙对接上网

交换机的三种模式:

Access模式:

一般用来连接计算机与交换机. 此模式下有一个PVID就是本端口所属的VLAN号,如果从链路上收到无标签的帧,则打上默认VLAN号,然后发给其他端口,如果从链路上收到有标签的帧,如果这个帧的VLAN等于PVID,则直接发给其他端口,如果不等于PVID,则直接丢弃.如果从其他端口收到一个有标签的帧,且VLAN等于PVID,则直接剥离掉标签从此端口发出,如果此标签不等于PVID,则直接丢弃.

Trunk模式:

一般用于各交换机之间连接.此模式下有一个PVID和允许通过的VLAN ID列表. 如果从链路上收到一个不带标签的帧,则直接打上PVID号,转发到其他端口, 如果从链路上收到一个带标签的帧,且此帧的VLAN号在允许通过的VLAN列表里,则直接转发给其他端口; 如果从其他端口收到一个有标签的帧,且此帧的VLAN等于PVID,则直接剥离掉标签,并从此端口发出,如果此标签不等于PVID,则查看此帧的VLAN号是否在允许通过的VLAN列表里,如果在,则直接从此端口发出,否则丢弃.

Hybrid模式:

此模式下,有一个默认的PVID号,一个untagged列表和一个tagged列表. 如果从链路上收到一个无标签的帧,则打上PVID号,转发到其他端口,如果从链路上收到一个带标签的帧,且此帧的VLAN号在untagged或者tagged列表中的其中任意一个列表里,则直接转发到其他端口,否则丢弃. 如果从其他端口收到一个有标签的帧,且帧的VLAN号在tagged列表里,则直接从此端口发出,如果VLAN号在untagged列表里,这剥离掉帧的VLAN标签,然后从此端口发出.
华为交换机的三种视图: 用户视图, 系统视图, 接口视图

用户视图: 刚开始登入交换机时的视图,一般看到的是尖括号<> .

save    // 配置完交换机后保存当前配置的命令
system-view    // 进入系统视图的命令
clock  timezone  BJ  add|minus 8   // 设置时区
clock  datetime  16:36:00 2016-07-01    //设置交换机的时间


系统视图: 在用户视图下输入system-view后进入系统视图,一般为方括号[]

display current-configuration  // 显示当前配置
user-interface maximum-vty 15  //配置vty最大连接数
user-interface vty 0 14     //进入vty用户界面视图
user privilege level 2      //设置vty登入的用户等级为2(配置用户级别)
authentication-mode aaa  //设置vty登入时的验证模式为用户名和密码验证

aaa  //进入AAA视图
local-user admin password cipher admin@123  //设置aaa登入的用户名和密码
local-user admin service-type telnet  //设置admin用户远程登入时的协议

user-interface console 0     //进入第0个console口的用户界面
authentication-mode passwd   //配置从console口登入交换机的认证模式为密码认证
set authentication password cipher admin@123  //配置从console口登入交换机的密码


vlan 10  //创建一个VLAN


interface meth 0/0/1   //进入交换机的第一个管理网口
ip address 192.168.1.110 24 //设置管理网口的ip地址和子网掩码

interface gigabitethernet 0/0/1 //进入第一个业务网口
port link-type access  //设置第1个网口位access模式
port default vlan 10   //设置此网口的VLAN号为10

interface gigabitethnet 0/0/2 //进入第2个业务网口
port link-type trunk   //设置第二个网口位trunk模式
port trunk allow-pass vlan 10 20 30  //设置此端口可以通过的VLAN号
             // port trunk allow-pass vlan all  表示可以通过所有的带VLAN的帧

Interface gigabitethnet 0/0/3  //进入第3个业务网口
Port link-type hybrid     //设置此端口为hybrid模式,每个端口默认就是hybrid模式
Port hybrid pvid vlan 10   //设置pvid为10
Port hybrid tagged vlan 20 30 40 //设置tagged列表为20,30,40
Port hybrid untagged vlan 50 60 //设置untagged列表为50,60

Display port vlan  //显示当前各端口的VLAN情况



清除某个端口的配置
Interface gigabitethernet 0/0/2
Clear configuration this
Undo shutdown

Interface gigabitethernet 0/0/3
Undo port default vlan  //access 模式的端口
Undo port link-type
Undo port hybrid pvid vlan vlanid  //hybrid 模式的端口
Undo port hybrid untagged vlan vlanid
Undo port hybrid tagged vlan vlanid
Undo port trunk pvid vlan  //trunk 模式的端口
Undo port trunk allow-pass vlan vlanid
Undo port link-type

恢复出厂设置s5700SI
在用户视图下(按Ctrl+z组合键回到用户视图)输入如下命令操作
reset saved-configuration
Y
Reboot
N
Y


设置交换机的mux-vlan模式
假设主VLAN是10,从VLAN中group模式的有VLAN 20, separate模式的有VLAN 30,server连接1号端口,PC1和PC2连接2和3号端口,PC3和PC4连接4和5号端口
Vlan batch 10 20 30
Vlan 10
Mux-vlan
Subordinate group 20
Subordinate separate 30
把各连接的端口设为access模式,并且加入到各自的VLAN中,且同时开启mux-vlan功能,
Interface gigabitethernet 0/0/1       
Port link-type access
Port default vlan 10
Port mux-vlan enable
Interface gigabitethernet 0/0/2       //3号端口设置方法类似
Port link-type access
Port default vlan 20
Port mux-vlan enable
Interface gigabitethernet 0/0/4      //5号端口设置方法类似
Port link-type access
Port default vlan 30
Port mux-vlan enable


三层交换机接路由器LAN口
Vlan 60 70
Interface vlanif 60
ip address 192.168.60.1 24
interface vlanif 70
ip address 192.168.1.238 24
interface gigabitethernet 0/0/3
port link-type access
port default vlan 60
interface gigabitethernet 0/0/4
port link-type access
port default vlan 70
ip route-static 0.0.0.0 0.0.0.0 192.168.1.1
在与交换机相连的路由器上设置一条静态ip地址,目的地址为交换机相关的各个网段地址,网关为交换机与路由器相连的vlanif的ip地址

 

批量配置交换机端口
vlan batch 10 20
port-group 1
group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10
port link-type access
port default vlan 10

 

 

点击下载此文件  华为三层交换机与防火墙对接上网

分类:学校网络 | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 44

思科(锐捷)三层交换机配置VLAN+DHCP

命令如下:

假设是配置vlan 网关,那么就是配置SVI接口IP地址:

enable
configure terminal
int vlan 10 (端口下命令)
ip address 192.168.10.1 255.255.255.0(确定vlan网段)
exit

DHCP配置:

ip dhcp pool vlan(设置名称)
network 192.168.10.0 255.255.255.0(设置网段)
default-rotuer 192.168.10.1(设置网关)
dns-server X.X.X.X   (设置DNS)
exit
ip dhcp e 192.168.10.1  (不分配IP)
分类:学校网络 | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 72

sublime使用技巧

1.右键支持用sublime2打开
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Sublime2]
@="Sublime2(&S)"

[HKEY_CLASSES_ROOT\*\shell\Sublime2\command]
@="\"C:\\Program Files\\Sublime Text\\SublimeText.exe\" -p --remote-tab-silent \"%1\""

把以下内容保存成一个sublime2.reg的注册表文件,双击打开即可!

2.支持vim模式
依次打开 选项->设置->默认,接着设置成以下即可:
"ignored_packages": []

3.安装vim增强插件VintageEx
依次打开 选项->浏览安装包,把VintageEx解压放到它下面即可,必须安装它,否则你的sublime只支持vim中的简单的模式并不支持末行模式

4.安装svn同步开发环境插件Tortoise
依次打开 选项->浏览安装包,把Toroise解压放到它下面即可,依次 选项->软件包设置->tortoise->key bindings - default中设置:
{ "keys": ["ctrl+alt+z"], "command": "tortoise_commit" },
所以我的快捷键是ctrl+alt+z即可向svn服务器提交更新

5.支持php和python查看页面的所有函数,可以快速定位函数,ctrl+r即可,或者按ctrl+shift+p后再输入@即可,并且还可以有来查看html中的id的缩略地图

6.支持c和python编译,你只需要按ctrl+b即可,当然前提要把c:\python27加入到系统的环境变量中

7.关闭前面的行号方法
依次打开 选项->设置->默认,接着设置成以下即可:
"line_numbers": false,

8. 关闭自动补全单双引号以及圆括号和大括号
"auto_match_enabled": false,

9.出现明显的当前操作行的背景线方法
"highlight_line": true,

10.修改默认编码方法
"default_encoding": "UTF-8",

11.转换当前文件字符集方法
依次 文件->gbk or utf-8

12.关闭侧边栏方法
依次 查看->侧边栏

13.关闭迷你地图方法
依次 查看->隐藏迷你地图

14.搜索当前目录下的其他代码文件方法
ctrl+shift+p

15.设置字体方法
"font_face": "",
"font_size": 18,

16.显示控制台方法
查看显示控制台或ctrl+~即可,控制台中可以使用python命令,但比较简短

17.排版缩进方法
先全选中,然后按tab键进行右缩进,然后按shift+tab进行左缩进

18.快速在切换一个()或{}代码段的开始和结尾方法
按shift+5即可

19.多鼠标操作方法
按ctrl键,同时点击多个地方,即可一次性操作多个地方,非常方便

20.快速注释和取消注释方法
用鼠标选中后,按ctrl+/或ctrl+shift+/,再按即可取消

21.sublime命令补全插件emmet,它会自动把snippet插件停止或开启,这是以前zen coding的升级版本,它主要是针对html这些前面代码的,它可以完全使用css选择器功能,以下是它支持的选择器命令:
E
元素名称(div, p);
E#id
使用id的元素(div#content, p#intro, span#error);
E.class
使用类的元素(div.header, p.error.critial). 你也可以联合使用class和idID: div#content.column.width;
E>N
子代元素(div>p, div#footer>p>span);
E+N
兄弟元素(h1+p, div#header+div#content+div#footer);
E*N
元素倍增(ul#nav>li*5>a);
E$*N
条目编号 (ul#nav>li.item-$*5);

如:div.vsa>ul#nav>li.item$*5>a{Item $}可以生成如下代码:
<div class="vsa">
    <ul id="nav">
        <li class="item1"><a href="">Item 1</a></li>
        <li class="item2"><a href="">Item 2</a></li>
        <li class="item3"><a href="">Item 3</a></li>
        <li class="item4"><a href="">Item 4</a></li>
        <li class="item5"><a href="">Item 5</a></li>
    </ul>
</div>

22.右侧缩略图区块加边框
"draw_minimap_border": true,

23.快速查看页面中的类和函数
ctrl+r

24.快速查看页面中的关键字
ctrl+;

25.设置左侧树结构
ctrl+alt+k
//选项->默认绑定:
{ "keys": ["ctrl+alt+k"], "command": "toggle_side_bar" },

26.在sublime中查看python类和函数:
Ctrl+r

27.在sublime中查看python关键字:
Ctrl+;

28.sublimeREPL插件非常的有用对学python来说,这样可以在工具->sublimeREPL->python->有几个非常有用的工具
1)python
2)python run current file

29.设置字体要在选项->设置->默认:
"font_size": 16.0

30.设置vi打开模式为命令,选项->设置->默认:
"vintage_start_in_command_mode": true

31.如何禁止自动更新
Preferences -> Settings-User
"update_check": false, 
保存即可。

32.如何去掉行尾空格?
点击菜单栏上的“Preferences->Setting-Default”,搜索“trim_trailing_white_space_on_save” 然后将false改为true,将在保存的时候去除行尾的空格。

33.sublime如何显示空格和换行
首选项->默认下把"draw_white_space": "all"即可.

34.打开当前编辑的文件目录
ctrl+o

35.直接到达匹配的括号
ctrl+m

36.如何在sublime中直接执行php
打开插件目录中的User,建一个文件php.sublime-build,内容为:
{
    "cmd": ["php", "$file"],
    "file_regex": "php$",
    "selector": "source.php"
}
保存后,在任何地方都可以建php文件,并且通过在ctrl+b即可执行

37.如何取消因为删除插件而导致的提示性错误:
插件目录->user->Package Control.sublime-settings中进行删除即可

38.如何按f12调出浏览器:
首选项->程序包->sidebar->默认设置中最后更改为firefox即可
 

分类:php | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 52

Sublime text 3最新版破解方法

Sublime Text3注册码(可用)

作为强大而小巧,性感且快捷的SublimeText,怎么能够允许不时弹个框提醒你购买,并且顶部有未注册这样破坏美感的存在呢?OK,点开Help,填入注册码即可消除此问题。

Sublime text 3 3103 注册码 ! (Update:2016-03-08)

—– BEGIN LICENSE —–
Michael Barnes
Single User License
EA7E-821385
8A353C41 872A0D5C DF9B2950 AFF6F667
C458EA6D 8EA3C286 98D1D650 131A97AB
AA919AEC EF20E143 B361B1E7 4C8B7F04
B085E65E 2F5F5360 8489D422 FB8FC1AA
93F6323C FD7F7544 3F39C318 D95E6480
FCCC7561 8A4A1741 68FA4223 ADCEDE07
200C25BE DBBC4855 C4CFB774 C5EC138C
0FEC1CEF D9DCECEC D3A5DAD1 01316C36
—— END LICENSE ——

—– BEGIN LICENSE —–
Nicolas Hennion
Single User License
EA7E-866075
8A01AA83 1D668D24 4484AEBC 3B04512C
827B0DE5 69E9B07A A39ACCC0 F95F5410
729D5639 4C37CECB B2522FB3 8D37FDC1
72899363 BBA441AC A5F47F08 6CD3B3FE
CEFB3783 B2E1BA96 71AAF7B4 AFB61B1D
0CC513E7 52FF2333 9F726D2C CDE53B4A
810C0D4F E1F419A3 CDA0832B 8440565A
35BF00F6 4CA9F869 ED10E245 469C233E
—— END LICENSE ——

查看更多...

分类:php | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 67

查询某一年 某一月 某一天的数据(可组合)

select * fromymt where date_format(inDate,'%Y-%m-%d')='2016-10-10';

 (inDate为表中列名)


查看更多...

分类:php | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 96

isset 判断变量是否已存在

empty 判断变量是否为空或为0

is_null 判断变量是否为NULL

变量 empty is_null isset
$a=”” true false true
$a=null true true false
var $a true true false
$a=array() true false true
$a=false true false true
$a=15 false false true
$a=1 false false true
$a=0 true false true
$a=”0” true false true
$a=”true” false false true
$a=”false” false false true
分类:php | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 93

php操作mysql常用的一些内置函数

1.使用数据库:

    连接数据库:

    $con = mysql_connect($hostname, $user, $pass);

查看更多...

分类:php | 固定链接 | 评论: 0 | 引用: 0 | 查看次数: 85